All systems operational

Third-party service provider issues are intermittently preventing pages from loading

Resolved
Degraded performance
Started about 1 year ago Lasted about 2 hours

Affected

Dashboard
API
Fundraising Pages
Updates
  • Resolved
    Resolved

    This issue has been resolved, and we no longer expect to experience any performance issues as a result of it.

  • Monitoring
    Monitoring

    We have deployed an update that avoids reliance on the affected third-party service. Performance issues appear to be resolved, and we will continue to monitor our systems to ensure the issue is resolved.

  • Identified
    Identified

    One of our third-party service providers is experiencing DNS resolution issues. This may prevent pages from loading across the admin dashboard and public-facing donation pages.

    We're currently monitoring the status of the issue and will provide an update as it is resolved.