Givebutter - Delayed Email Deliveries – Detalles del incidente

Sistemas funcionando con normalidad

Delayed Email Deliveries

Resuelto
Interrupción mayor
Iniciado el hace 3 díasDuró 27 minutos
Actualizaciones
  • Resuelto
    Resuelto

    All emails are now being delivered as expected. Thank you for your patience. 

  • Investigando
    Investigando

    We are currently investigating delays in outbound email delivery. Some emails may be delivered later than expected. Donation processing and other platform functionality are not affected.