Scheduled for August 19, 2025 at 5:00 AM – 5:18 AM
Affects
Dashboard
Under maintenance from 5:00 AM to 5:18 AM
API
Under maintenance from 5:00 AM to 5:18 AM
Fundraising Pages
Under maintenance from 5:00 AM to 5:18 AM
Updates
Completed
August 19, 2025 at 5:18 AM
Completed
August 19, 2025 at 5:18 AM
Maintenance has completed successfully.
In progress
August 19, 2025 at 5:00 AM
In progress
August 19, 2025 at 5:00 AM
Maintenance is now in progress
Planned
August 19, 2025 at 5:00 AM
Planned
August 19, 2025 at 5:00 AM
Givebutter is performing scheduled maintenance on Tuesday, August 19th from 1:00am to 2:00am ET. You might notice a few brief hiccups during this hour while we make everything run even smoother for you. Please check back here for updates.